[Arreglado] Error con RSS y el reader

Los problemas del sitio que se van solucionando, son movidos aquí.
Responder
Avatar de Usuario
Enosh
n00b
n00b
Mensajes: 11
Registrado: Vie Oct 16, 2009 12:59 pm

[Arreglado] Error con RSS y el reader

Mensaje por Enosh » Lun Nov 16, 2009 9:28 pm

-Arreglado. Aseguraos de actualizar las direcciones de los feeds.

No sé si me ocurre solo a mi (y es mi culpa) o alguien más, por lo que he visto nadie ha abierto un tema similar:
Uso el reader de google para seguir los blogs de magic a los que me he adscrito, y por este sistema, las entradas de moxes me dan un error. Al clikar en el enlace a la entrada se me abre la correspondiente pestaña con este mensaje de ¿error?:
Not Acceptable

An appropriate representation of the requested resource /index.php could not be found on this server.

Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.2.14 (Unix) mod_ssl/2.2.14 OpenSSL/0.9.7a mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 PHP/5.2.11 Server at http://www.moxes.com Port 80
Decir que he probado a suscribirme al Rss por varios medio a ver si evitaba esto: por los enlaces del propio Blog, buscando el blog desde el reader, y el resultado es el mismo. Decir que por lo demás el funcionamiento de la web usandola de modo normal es correcto. Mi navegador habitual es Mozilla, pero en el Explorer 8 tengo el mismo problema.

¿Que he hecho mal? :oops:
Gracias de antemano.
Avatar de Usuario
Vaevictis_Asmadi
Pro del Foro
Pro del Foro
Mensajes: 879
Registrado: Sab Ago 29, 2009 4:55 am

Re: Error con RSS y el reader

Mensaje por Vaevictis_Asmadi » Lun Nov 16, 2009 10:06 pm

Enosh no eres el único, pero es que no puedo reproducir el problema. Acabo de suscribirme al feed de las entradas con el Google Reader y funciona perfectamente. Aparte que ya he probado todos los feeds varias veces.

¿Alguien puede confirmar esto?

Yo que sé, asegúrate que usas la dirección completa del feed, es un poco larga. Es lo primero que se me ha ocurrido :lol:.
Hvirfilvindr escribió:We already know that Ancestral Recall is generally better than Sift. We also know that ice cream is generally better than a kick in the pants.
Avatar de Usuario
Enosh
n00b
n00b
Mensajes: 11
Registrado: Vie Oct 16, 2009 12:59 pm

Re: Error con RSS y el reader

Mensaje por Enosh » Lun Nov 16, 2009 11:18 pm

He probado a borrar mi suscripción y a volver a suscribirme de diferentes maneras: A traves de los enlaces de Feed de la propia pagina (" RSS entradas"), directamente desde el reader añadiendo la direción moxes.com, o la del Feed (http://www.moxes.com/index.php?option=c ... &feed_id=2).

Un dato curioso es que en el propio reader las entradas se ven perfectamente, y es solo cuando intento acceder desde el visor del igoogle (un gadget de estos que aparecen en la potada del gogle personalizable) es cuando me salta el fallo. Solo me pasa con este Blog, y leo como 20 distintos.

Lo que no he dicho y es relevante es que esto ocurrío tras el cambio de Web; en un primer momento me llegaban duplicadas las entradas (aunque no de forma simultanea, y no, no era por que estaba suscrito a la web anterior todavía) y cuando me di de baja y volví a suscribirme a ver si lo solucionaba, es cuando apareció este error. Así fue si no recuerdo mal, pero puede que aún así no guarde relación ni el cambio de web, ni los mensajes duplicados con este prolema.

En fin. Que siento dar la brasa.
Avatar de Usuario
Vaevictis_Asmadi
Pro del Foro
Pro del Foro
Mensajes: 879
Registrado: Sab Ago 29, 2009 4:55 am

Re: Error con RSS y el reader

Mensaje por Vaevictis_Asmadi » Mar Nov 17, 2009 6:23 pm

Nos ha mandado un e-mail un lector extranjero (o más bien espectador porque decía que español no hablaba :lol:) y nos ha dicho directamente el problema:

En los enlaces de los títulos de las entradas (en los Leer Más no) las entidades html se codifican dos veces; pero como los readers sólo decodifican la única vez esperada, las direcciones no son válidas.

Las direcciones contienen '&'. Su entidad html correspondiente es '&'. La segunda vez que se codifican las entidades ese '&' se convierte en '&' y ya la hemos cagado. La decodificación del reader te da ese primer '&', cuando debía de darte el '&' original.

Esto tiene pinta de ser un bug del componente de Joomla que usamos para generar los feeds. Lo he actualizado pero sigue ahí, así que lo reportaré y cuando tenga tiempo veré si encuentro el código culpable, mientras el programador contesta o no.

De momento podéis usar los enlaces Leer Más, que sí están bien.
Hvirfilvindr escribió:We already know that Ancestral Recall is generally better than Sift. We also know that ice cream is generally better than a kick in the pants.
Avatar de Usuario
Enosh
n00b
n00b
Mensajes: 11
Registrado: Vie Oct 16, 2009 12:59 pm

Re: Error con RSS y el reader

Mensaje por Enosh » Mié Nov 18, 2009 9:36 am

Como no entendido de la informática me hago solo una idea vaga del probema, pero se agradece el tiempo y el esfuerzo. Si hay algún cambio lo reportaré, por si es de ayuda.
Avatar de Usuario
Vaevictis_Asmadi
Pro del Foro
Pro del Foro
Mensajes: 879
Registrado: Sab Ago 29, 2009 4:55 am

Re: Error con RSS y el reader

Mensaje por Vaevictis_Asmadi » Mié Nov 18, 2009 5:16 pm

Mientras no sacan una nueva versión del componente, he "hackeado" la parte que usamos para que no pase.

Ya no debería fallar. Según el feed que use cada uno, ya o en una hora se verá el cambio.
Hvirfilvindr escribió:We already know that Ancestral Recall is generally better than Sift. We also know that ice cream is generally better than a kick in the pants.
Avatar de Usuario
Azinger
Netdecker
Netdecker
Mensajes: 46
Registrado: Lun Oct 05, 2009 11:59 am

Re: Error con RSS y el reader

Mensaje por Azinger » Mié Nov 18, 2009 6:02 pm

yo uso netvibes y sigue muerto...
Avatar de Usuario
Vaevictis_Asmadi
Pro del Foro
Pro del Foro
Mensajes: 879
Registrado: Sab Ago 29, 2009 4:55 am

Re: Error con RSS y el reader

Mensaje por Vaevictis_Asmadi » Mié Nov 18, 2009 7:44 pm

Muerto nunca ha estado...

Es que lo dije mal, no era una hora como máximo, sino como mínimo :lol: (por el cache). Casi un cuarto de hora después de tu post.

Ya no hay cache que valga y debería estar todo bien.
Hvirfilvindr escribió:We already know that Ancestral Recall is generally better than Sift. We also know that ice cream is generally better than a kick in the pants.
franfreeman
n00b
n00b
Mensajes: 24
Registrado: Jue Oct 22, 2009 4:32 pm

Re: Error con RSS y el reader

Mensaje por franfreeman » Mié Nov 18, 2009 9:28 pm

en imtg.es tampoco van los enlazes
Avatar de Usuario
Vaevictis_Asmadi
Pro del Foro
Pro del Foro
Mensajes: 879
Registrado: Sab Ago 29, 2009 4:55 am

Re: Error con RSS y el reader

Mensaje por Vaevictis_Asmadi » Mié Nov 18, 2009 10:43 pm

  1. Imposible, arreglé el fallo en los feeds a las 17:15.
  2. Lo acabo de comprobar en imtg.es y van bien.
Información actualizada señores, que quiero mover esto a Resueltos.
Hvirfilvindr escribió:We already know that Ancestral Recall is generally better than Sift. We also know that ice cream is generally better than a kick in the pants.
Avatar de Usuario
Azinger
Netdecker
Netdecker
Mensajes: 46
Registrado: Lun Oct 05, 2009 11:59 am

Re: Error con RSS y el reader

Mensaje por Azinger » Jue Nov 19, 2009 9:47 am

A mi con netvibes ahora mismo me sigue sin funcionar, me dice que el canal no es valido o no responde, muerto vamos :)
Avatar de Usuario
Enosh
n00b
n00b
Mensajes: 11
Registrado: Vie Oct 16, 2009 12:59 pm

Re: Error con RSS y el reader

Mensaje por Enosh » Jue Nov 19, 2009 11:25 am

Confirmo que el Google reader ya abre perfectamente las entradas. Por mi parte está solucionado. Muchisimas gracias.
Deathgenta
Netdecker
Netdecker
Mensajes: 67
Registrado: Dom Oct 04, 2009 11:30 am

Re: Error con RSS y el reader

Mensaje por Deathgenta » Jue Nov 19, 2009 4:16 pm

Si sirve de algo, dire que a mi tambien me funciona el link de imtg.es. El titulo de las entradas ya sale normal, no como antes que te salia el primer parrafo de la noticia.
Avatar de Usuario
Vaevictis_Asmadi
Pro del Foro
Pro del Foro
Mensajes: 879
Registrado: Sab Ago 29, 2009 4:55 am

Re: Error con RSS y el reader

Mensaje por Vaevictis_Asmadi » Jue Nov 19, 2009 4:53 pm

Azinger escribió:A mi con netvibes ahora mismo me sigue sin funcionar, me dice que el canal no es valido o no responde, muerto vamos :)
No sé si te has dado cuenta, pero la URL de los dos feeds de la web (entradas y noticias) cambió ayer cuando actualicé la extensión de Joomla que los genera. Actualízala y mira de nuevo.

Por otro lado existe una URL de feedburner (http://feeds.feedburner.com/moxes) que apunta al feed de entradas de la web, que es la que está usando imtg.es.

Repito, ahora mismo todo funciona, así que nadie debería tener ningún problema. ¿Sí o no?

-El que calla otorga. Solucionado hasta que alguien diga lo contrario.
Hvirfilvindr escribió:We already know that Ancestral Recall is generally better than Sift. We also know that ice cream is generally better than a kick in the pants.
Responder